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1 About this document

1.1 Other applicable documents

The information on the Safety Sensor is distributed over several documents to
make working with the documents easier. The documents and software for the
Safety Sensor are provided in the following table:

* identifies the product that the Safety Sensor is installed in.

** You download the current version of the software and all documents as PDF on
the Internet at: http://www.leuze.de/rotoscan

Purpose and target group of the 
document

Document/software 
title

Source

Basic information for all users of the 
machine*; on paper so that the 
information is always at hand

Application information Art. no. 607140**
Included with the product 
delivery as print and on 
CD-ROM

Software for users of the machine* 
for Safety Sensor diagnostics if a 
fault occurs and for the machine 
designer* for configuring the Safety 
Sensor

RS4soft Included with the product 
delivery on CD-ROM**

Information for the machine 
designer* 

Safe implementation and 
operation

Art. no. 607142**
Included with the product 
delivery on CD-ROM

Notes for the machine designer* for 
configuring the Safety Sensor 
(RS4soft software instructions)

Safe parametering 
(this document)

Art. no. 607141**
Included with the product 
delivery on CD-ROM

ROTOSCAN RS4/AS-i 
additional information

ROTOSCAN RS4-4 
connecting and 
operating instructions 
additional information 

Art. no. 607060**
Included with the product 
delivery on CD-ROM

ROTOSCAN RS4/PROFIsafe 
additional information

ROTOSCAN RS4-4 
Laser Scanner 
connecting and 
operating instructions 
additional information 

Art. no. 605054**
Included with the product 
delivery on CD-ROM
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1.2 Means of illustration used

Table 1.1: Warning signs and signal words

Table 1.2: Further symbols

Symbol for dangers

NOTICE Signal word for damage to property
Indicates dangers that could damage the Safety Sensor if the measures 
for preventing danger are not implemented.

CAUTION Signal word for minor injuries
Indicates dangers that could slightly injure you if the measures for 
preventing danger are not implemented.

WARNING Signal word for serious injuries
Indicates dangers that could seriously or fatally injure you if the measures 
for preventing danger are not implemented.

DANGER Signal word for danger to life
Indicates dangers that could seriously or fatally injure you if the measures 
for preventing danger are not implemented.

Symbol for tips
Texts with this symbol provide you with further information on handling 
the software.

Symbol for action steps
Texts with this symbol instruct you on how to perform actions.
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2 System requirements

Computer
You require a PC or laptop with the following to use the software:

Processor type Intel® Pentium or comparable, e.g.  AMD® or Cyrix®

Operating system Microsoft® Windows 95/98/NT®/2000/XP®

RAM At least 64 MB

Hard disk memory At least 50 MB free memory
You require more memory space if you want to save 
protective field or configuration values.

Screen display Color

External drive CD drive

Input device Keyboard and mouse or touchpad

Output device Printer (black and white or color)

Serial interface RS232 or RS422 
Use an appropriate adapter if the PC has a USB 
interface instead of a serial interface.

Only the term "PC" will be used in the following.
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3 Scope of function
You can configure the ROTOSCAN RS4 Safety Sensor and perform diagnostics
with the software. The communication is performed here via the PC.

3.1 Configuration

To put the Safety Sensor into operation in your application, you must adjust the
Safety Sensor individually via the software. 

The Safety Sensor is configured at the factory and delivered with a default
configuration. 

The default configuration is stored as a file in the program directory during the
software installation.

3.1.1 Configuring the Safety Sensor

The software saves all the data of a configuration in a configuration file.
A configuration file has the *.rs file format and includes all the information that the
Safety Sensor requires for the operation.
A Safety Sensor's configuration file includes the following data:

• Administrative data, e.g.  description 
• Safety-relevant data, e.g.  startup process 
• Protective or warning field configuration data, e.g.  contours and limits

A wizard guides you through the configuration. 

3.1.2 Configuring protective and warning fields

Several configurable field pairs are available for the Safety Sensor. A field pair
consists of a protective field and a warning field.

A field configuration file has the *.sf file format and includes data on the size of a
single protective or warning field, e.g.  contours and limits.

Only use the software for Safety Sensors manufactured by Leuze electronic.
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3.2 Diagnostics

During operation you can graphically display measured data transferred from the
Safety Sensor to the PC and measured contours with the software. The software
constantly compares the protective and warning fields with the measured room
contour and shows protective field interruptions in real-time.
During the Safety Sensor configuration you can analyze coordinates in the
software, e.g.  for using automated guided vehicle systems (AGVs). 
For the MotionMonitoring function the wizard supports you with two additional
dialog boxes with the effective startup.

Pic. 3.1: Additional dialog box for MotionMonitoring

For the system test you can perform extended status and operation diagnostics
with the software. You can, for example,  load status information from the Safety
Sensor, print a diagnostics list, and create a service file for Support.
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4 User interface

4.1 Screen setup

The software graphically displays the measured and configured field contours. 
The screen structures itself in several areas in which you can display and edit/
process data. Various control elements are provided on the user interface to call
up the required functions. 

Pic. 4.1: Screen setup

55

11 22 33
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4.2 Topic bar

In the top area of the screen you will find the topic bar with the following entries:
• Measured contour display
• Configuration
• Protective/warning fields definition
• System data

Each topic bar includes the toolbar with standard buttons and buttons for special
functions (see chapter, "Buttons", page 65). If you click on an entry in the topic
bar, you can use the functions of the selected operating mode (according to your
authorization level).

Position Name Description

1 Menu bar Includes menus with menu items and sub menus (see 
chapter, "Menu", page 58).

2 Topic bar with toolbar Includes operating modes with toolbar and topical task 
bars (see chapter, "Topic bar", page 11).

3 Work space Graphically displays measured and room contour and 
protective/warning fields and allows them to be 
processed (see chapter, "Work space", page 12).

4 Navigation area Shows XY coordinates of the cursor position (end 
position) and includes buttons for positioning the contour 
field (see chapter, "Navigation area", page 13).

5 Status line Informs, for example,  about connection and login (see 
chapter, "Status line", page 13). 

6 Information area Names active and selected field pairs and data source.

Each entry of the topic bar corresponds with an operating mode. Note! The
available entries of the topic bar depend on the selected authorization level. 
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4.3 Work space

The Work space screen area is used for graphically displaying measured and
room contours and protective and warning field pairs. The software uses the
following colors to differentiate the contours:

Table 4.1: Contour colors

Pic. 4.2: Contour display

You recognize the cursor position by a dark-blue circle that changes to a
crosshairs when clicked.
With the appropriate authorization you can edit protective and warning fields on
the work space (see chapter, "Edit protective and warning fields", page 33).

Contour Color

Minimum protective field Gray

Protective field Red

Warning field Green

Deactivated protective 
field

Bright gray

Deactivated warning field Dark gray

Measured contour Yellow/red
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4.4 Navigation area

In the navigation area the software shows the XY coordinates of the cursor
position during the protective and warning field definition. When you click on the
work space and pull out a zone with the mouse button pressed, the software
shows the area in the position and end position lines. With these coordinates you
can precisely locate objects on the work space and display them in detail.
With the arrow buttons arranged in a cross, you can move the displayed image
section on the work space. Click on the middle button to optimally position the
entire contour field. 

Pic. 4.3: Navigation buttons

4.5 Status line

In the Status line screen area you receive detailed information in five fields about:

• The communication between PC and Safety Sensor
• The Safety Sensor status
• The selected operating mode of the software
• The active protective/warning field status
• The logged on user's authorization level

Table 4.2: Communication

Table 4.3: Safety Sensor

Display Status

RS4 synchronous PC synchronizes the connection between the PC and the 
Safety Sensor

RS4 connection Data transfer between PC and Safety Sensor is possible

Display Status

RS4 -> Measurement mode Software records measurement data from the Safety 
Sensor

RS4 -> Configuration Software transfers configuration data to the Safety Sensor 
(Sods switched off)

RS4 -> Error Error in the Safety Sensor (Sods switched off)
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Table 4.4: Operating mode

Table 4.5: Protective/warning field

Table 4.6: Logged-on authorization level

Display Status

PC -> Measured value 
display

Software in measured contour display operating mode

PC -> RS4 configuration Software in configuration operating mode

PC -> Protective/warning 
field definition

Software in protective/warning field definition operating 
mode

PC -> RS4 system data Software in system data operating mode

Display Status

PF/WF red Protective and warning field interrupted (Sods switched off)

WF green Warning field interrupted

Empty Protective and warning field free

Display Status

Operator (Op) User is logged in with the Operator (Op) authorization level

Maintainer (Ma) User is logged in with the Maintainer (Ma) authorization 
level

Authorized Customer (AC) User is logged in with the Authorized Customer (AC) 
authorization level

Production (Pr) User is logged in with the Production (Pr) authorization 
level.

Development (De) User is logged in with the Development (De) authorization 
level.
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5 Operate

5.1 Procedure when configuring

Proceed as follows to configure a Safety Sensor:

Connect PC with Safety Sensor

Start software and log in user

Create Safety Sensor configuration with the wizard

Create protective/warning field configuration

Transfer configuration to the Safety Sensor

Check echo data

5.2 Install software

Requirements:
• You do not need the Safety Sensor to install the software on the PC. If the 

devices are already connected with one another, ensure that the Safety 
Sensor is switched off.

• All Windows applications are closed. 

Insert the CD ROM. 

The installation starts automatically. 

If the installation does not start automatically, double-click on the setup.exe file.

If you want to open the CD's menu, double-click on the setup.exe file.

Select a language for the interface texts in the installation wizard and in the 
software and confirm with [OK].

The installation wizard starts.

Click on [Next]. 

The installation wizard opens the software license contract.

If you agree with the software license contract, click on [Yes]. 
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If you agree with the recommended installation path, click on [Next].

or

If you want to enter another path, click on [Search]. Select another path, 
confirm with [OK] and click on [Next]. 

The wizard installs the software and creates a link on the desktop.

5.3 Log in user

The following chapters provide basic information on the various access rights and
the actual login process.

5.3.1 Authorization concept

The access administration enables a target group-oriented login. The functions
that are available depend on the selected authorization level. Functions that are
not available in the software are identified by the bright gray buttons.
You do not require any individual user names for the login, but you must select an
authorization level. The following authorization levels are available:
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Table 5.1: Authorization levels and available functions

Authorization level Functions

Operator (Op) • Adjust display
• Display and analyze measured contour
• Load configuration data from the Safety Sensor
• Load status information from the Safety Sensor
• Display diagnostics list
• Create service file
• Reset password

Maintainer (Ma) In addition to the Operator (Op) functions: 
• Load configuration data from the Safety Sensor
• Load configuration data from file 
• Load configuration data from file and transfer to the Safety 

Sensor
• Transfer configuration data from the PC to the Safety 

Sensor
• Print configuration data
• Print protective/warning field

Authorized Customer 
(AC)

In addition to the Maintainer (Ma) functions, full access to all 
user-relevant functions and parameters: 

• Save configuration data as a file
• Change all configuration parameters
• Reset Safety Sensor to default values 
• Define and change protective/warning fields
• Set reference contour in the protective field
• Print and delete protective/warning fields
• Load protective/warning field data from file
• Save protective/warning field data
• Transfer protective/warning field data from the PC to the 

Safety Sensor
• Calibrate the front screen
• Change passwords

Production (Pr) Manufacturer-specific access

Development (De) Manufacturer-specific access
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All authorization levels except Operator (Op) are protected with a password.
There are the following password types: 

• Default password: Valid for the software, cannot be changed
• Specific password: Valid for the Safety Sensor

The password that you must enter in the software depends on the login situation:

Table 5.2: Login situations and password types

5.3.2 Login

Using software without Safety Sensor
You can use the software without the Safety Sensor, e.g.  to edit existing
configurations. The functionality of the software is limited. 
Requirements:

• Software and Safety Sensor are not connected.
• The R232 serial interface must be active on the PC. If, for example,  you 

use a laptop with a USB adapter, you must first install this interface where 
necessary. 

Click on [Start] in the taskbar. 

In the start menu select Program > Leuze electronic > RS4soft > RS4soft.

The software starts.
The start screen with information on the version opens. 
The Change authorization level dialog box opens.

The software saves the specific password in the connected Safety Sensor and
therefore ensures that only authorized users can change the existing
configuration.

Login situation Password type

Software is not connected with Safety Sensor Default password

Software is connected with Safety Sensor Specific password

Use the default password when you log in on the Safety Sensor for the first
time. Change the default password immediately to a specific password. More
information is provided in chapter "Login" on page 18 and chapter "Change
password" on page 54.
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In the Authorization level list select the Authorized Customer (AC) entry and 
enter the RS4LEUZE default password. 

Confirm with [OK].

You can use the offered wizard (see page 24) and load a configuration from a file
(see page 21).

Using software with the Safety Sensor
You can use the software with the Safety Sensor connected, e.g.  to transfer an
existing configuration to the Safety Sensor. 
Requirements:

• The Safety Sensor is connected to the power supply. 
• The Safety Sensor is connected to the PC and turned on.

Click on [Start] in the taskbar. 

In the Windows® start menu select the menu items  All programs > Leuze 
electronic > RS4soft > RS4soft.

The software starts.
The start screen with information on the version opens. 
The Safety Sensor automatically contacts the connected PC.
The software automatically synchronizes the PC and the Safety Sensor.
The software automatically transfers the configuration from the Safety Sensor 
and checks the data.
The Change authorization level dialog box opens.

Change the entry in the Authorization level list. If you have selected the 
Maintainer (Ma) or Authorized Customer (AC) entry, you must enter a 
password (see page 16).

When you log in for the first time, enter a suitable default password for your 
authorization level: 

Maintainer (Ma): RS4IGOY

Authorized Customer (AC): RS4LEUZE 

Confirm with [OK].

If you switch on the Safety Sensor after the software start and have selected the
Maintainer (Ma) or Authorized Customer (AC) authorization level, you must first
log in to the software with the default password. 
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If you have logged in with the Maintainer (Ma) or Authorized Customer (AC) 
authorization level for the first time, you must change your password (see 
page 64).

The software contacts and checks the connected Safety Sensor. 
The Scanner status information message appears.

The status information includes administrative and safety-relevant parameters. 
Compare all safety-relevant parameters with the required parameters of the 
current application (see chapter, "Print status information", page 49).

Click on [Close]. 

You can execute the functions available on your authorization level. If you have
logged in with the Authorized Customer (AC) or Maintainer (Ma) authorization
level, you can use the offered wizard (see page 24) and load a configuration from
a file (see page 21).

5.4 Create new Safety Sensor configuration

To create a new configuration, load an existing configuration and change its
parameters. You will find basic information about configurations in chapter (see
chapter, "Configuring the Safety Sensor", page 8). 

See also:
• Load Safety Sensor configuration (see page 21)
• Change Safety Sensor configuration parameters (see page 23)

5.5 Change existing Safety Sensor configuration

To change an existing configuration, load a configuration file and change the
configuration.
See also:

• Load Safety Sensor configuration (see page 21)
• Change Safety Sensor configuration parameters (see page 23)

A default configuration file is stored in the Examples folder of the program
directory. This configuration file standard.rs corresponds with the Safety
Sensor's standard configuration in its delivery status. You can use and change
the default configuration file as a template.
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5.6 Load Safety Sensor configuration 

To create a new configuration or to change an existing configuration, you must
first load an existing configuration. You can either open a locally saved
configuration file or get the configuration from the Safety Sensor. 

See also:
• Load from file (see page 21)
• Get from the Safety Sensor (see page 23)

5.6.1 Load from file

You can load a configuration from the PC, e.g.  from the hard disk or from an
external drive. 
If no Safety Sensor is connected, the load process starts after a password-
protected login and use of the configuration wizard.
Requirement:

• You are logged in with the Maintainer (Ma) or Authorized Customer (AC) 
authorization level.

Select Settings > Operating mode > Configuration.

or

Click in the topic bar on [Configuration].

Select File> Load configuration data from file.

or

Click on .
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If you use the software without the Safety Sensor, the Select Safety Laser 
Scanner dialog box opens before the configuration wizard starts:

In the Safety Laser Scanner list, select the Safety Sensor that you want to 
configure and click on [Close].

The file selection dialog box opens. The Examples folder is preset in the 
program directory. 

Select a file and click on [Open].

The software loads the configuration file and confirms success with a 
message.

Confirm with [OK].
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5.6.2 Get from the Safety Sensor

You can load the configuration file saved in the Safety Sensor in the software. If
the Safety Sensor is connected with the PC and switched on, the process starts
after the program start.

Requirement:
• You are logged in with the Maintainer (Ma) or Authorized Customer (AC) 

authorization level.

Select Settings > Operating mode > Configuration.

or

Click in the topic bar on [Configuration].

Select Configuration > Get configuration data from the scanner. 

or

Click on .

The software loads the configuration file from the Safety Sensor and shows the
status information (see chapter, "Login", page 18).

5.7 Change Safety Sensor configuration parameters

To change the parameters of a loaded configuration, you can change individual
parameters in a dialog box or use the configuration wizard.
See also:

• Change parameters with the configuration wizard (see page 24)
• Change individual parameters (see page 25)

The parameters that are offered depend on the Safety Sensor.



Operate

24 RS4soft Leuze electronic

5.7.1 Change parameters with the configuration wizard

You can change the parameters of the Safety Sensor configuration with a wizard.
If the Safety Sensor is connected with the PC and switched on, the process starts
after the login.

Requirements:
• You are logged in with the Authorized Customer (AC) authorization level.
• A configuration is loaded in the software.

Select Settings > Operating mode > Configuration.

or

Click in the topic bar on [Configuration].

Select Configuration > Wizard. 

or

Click on .

The configuration wizard starts. Administrative and safety-relevant parameters 
are thematically combined on several pages.

Enter the values of the parameters that you want to change in the 
corresponding fields. Click on [Next] to go the next page. Click on [Back] to go 
the previous page.

Confirm with [OK] when you have made all entries.

The configuration dialog closes. 

If the software is connected with the Safety Sensor, the Memory message 
dialog box opens. You can transfer the data from the PC to the Safety Sensor 
and save it in a file.

Ensure that the checkbox in front of the required function is active and confirm 
with [OK].

The software executes the selected functions. More information is provided in 
chapter "Transfer configuration data from the PC to the Safety Sensor" on 
page 28 and chapter "Save configuration data as a file" on page 30.

or

If you want to discard the changes to the configuration, click on the [Discard] 
button.

The software resets all changes to the configuration to the last memory status.

or

Click on [Cancel] if you want to edit the configuration further.
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5.7.2 Change individual parameters

You can change the parameters of the Safety Sensor configuration in a dialog
box. Administrative and safety-relevant parameters are combined in folders with
the same name. Protective and warning fields that belong together are combined
in the folders Field pair 1 to Field pair 4 respectively. 

Pic. 5.1: Configuration parameters dialog box

1 Folder selection
2 Parameter selection
3 Change single value parameters in input area (inactive)

Requirements:

• You are logged in with the Authorized Customer (AC) authorization level.
• A configuration is loaded in the software.

11 22 33

You cannot change parameters in R status (read only).
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Select Settings > Operating mode > Configuration.

or

Click in the topic bar on [Configuration].

Select Configuration > Change. 

or

Click on .

The Configuration parameters dialog box opens. 

Click on the folder that you want to change the parameters of. 

The software shows the folder's parameters in the parameter selection.

Double-click on the parameter that you want to change.

If you have selected a single value parameter, an area on the right inside the 
configuration dialog opens. The current value is shown and a entry field for the 
new value is provided.
or
If you have selected a multi value parameter, a dialog box with entry fields 
opens, provided with the current values.

Change the required parameter. 

When you have changed a parameter in the configuration dialog, click on 
[Accept].

or

If you have changed the parameters in the separate configuration dialog, 
confirm with [OK].

The separate dialog closes. You are now in the original configuration dialog.

Click on [Print] if you want to print the configuration.

Click on [Create text file] if you want to save the configuration in the *.txt format.

Confirm with [OK] when you have changed all parameters.

You can transfer the changed configuration to the Safety Sensor (see page 28) or
save it in a file (see page 30). 
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If you change the operating mode before you have transferred or saved the
changed configuration, the Memory message dialog box opens:

Ensure that the checkbox in front of the required function is active and confirm 
with [OK].

The software executes the selected functions. More information is provided in 
chapter "Transfer configuration data from the PC to the Safety Sensor" on 
page 28 and chapter "Save configuration data as a file" on page 30.

or

If you want to discard all changes to the configuration, click on the [Discard] 
button.

The software resets all changes to the configuration to the last memory status.

or

Click on [Cancel] if you want to edit the configuration further.
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5.8 Save Safety Sensor configuration

To save the configuration changed in the software, you can transfer the
configuration file to the Safety Sensor of save it in a file on the PC.
See also:

• Transfer configuration data from the PC to the Safety Sensor (see page 28)
• Save configuration data as a file (see page 30)

5.8.1 Transfer configuration data from the PC to the Safety Sensor

In order that your changes to the configuration become effective, you must
transfer the changed configuration file to the Safety Sensor.
Requirements:

• Software and Safety Sensor are connected.
• You are logged in with the Maintainer (Ma) or Authorized Customer (AC) 

authorization level.
• The changed configuration file is loaded in the software.

Select Settings > Operating mode > Configuration.

or

Click in the topic bar on [Configuration].

Select Configuration > Transfer from PC to scanner. 

or

Click on .

The software checks the configuration file and transfers it to the Safety Sensor. 

If you have changed administrative parameters, the Safety Sensor does not 
send any echo data. 

If you have changed safety-relevant parameters, the Safety Sensor sends 
echo data to the PC. 

To document the configuration you can print the configuration file or save it as
a text file in the *.txt format (see page 50).

Alternatively you can transfer a configuration saved on the PC as a file directly
to the Safety Sensor (see Page 61: Menu item Configuration > Load from file
and transfer to scanner).
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The Scanner echo data message appears: 

Check the echo data and confirm the message with [Accept].

The Scanner protective field echo data message opens for each changed 
protective field, and graphically and numerically displays the changed 
protective field.

Check the protective field echo data of all protective fields.



Operate

30 RS4soft Leuze electronic

If the protective field echo data is correct, confirm the message with [Accept].

The software checks the configuration file and transfers it to the Safety Sensor 
again.
The Configuration data transfer from PC to scanner message opens.

Confirm the message with [OK].

The software has saved the configuration file in the Safety Sensor.

5.8.2 Save configuration data as a file

You can save the loaded configuration on the PC, e.g.  on the hard disk or on an
external drive. 

Requirements:
• You are logged in with the Authorized Customer (AC) authorization level.
• The changed configuration file is loaded in the software.

Select Settings > Operating mode > Configuration.

or

Click in the topic bar on [Configuration].

Select File > Save configuration data as a file.

or

Click on .

The dialog box for saving opens. The Examples folder is preset in the 
program directory. 

Provide the file with a name and click on [Save].

The software saves the configuration file in the *.rs format.

Select the Save configuration data as a file function if, for example,  a Safety
Sensor is not connected with the PC. You can transfer a configuration saved on
the PC as a file later to the Safety Sensor.



Operate

Leuze electronic RS4soft 31

T
N

T
 3

5/
7-

24
V

5.9 Create new protective/warning field configuration

To create a new protective/warning field configuration, load an existing protective/
warning field configuration and change its contours. You will find basic information
about configurations in chapter "Configuration" on page 8. 

See also:
• Load Safety Sensor configuration (see page 21)
• Change existing protective/warning field configuration (see page 31)

5.10 Change existing protective/warning field configuration

To change an existing protective/warning field configuration, load an existing
protective/warning field configuration and change its contours. You will find basic
information about configurations in chapter "Configuring the Safety Sensor" on
page 8. 

See also:
• Load Safety Sensor configuration (see page 21)
• Load protective/warning field configuration (see page 32)

A Safety Sensor configuration must be loaded in the software so that you can
make changes to a protective or warning field. 
You can save the data of an individual protective or warning field configuration
as its own file. When you save the Safety Sensor's configuration file, the
protective or warning field file is automatically included in the Safety Sensor's
configuration file.

A Safety Sensor configuration must be loaded in the software so that you can
make changes to a protective or warning field.
You can save the data of a protective/warning field configuration as its own file.
The file of the Safety Sensor's configuration includes the protective/warning field
files of all defined field pairs.
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5.11 Load protective/warning field configuration

To create a new protective or warning field configuration or to change an existing
protective or warning field configuration, you must first load an existing protective
or warning field configuration. 

You can load an individual protective or warning field configuration from a file. If
a Safety Sensor configuration is already loaded, all defined protective/warning
fields in it are automatically loaded. 
See also:

• Get from the Safety Sensor (see page 23)
• Load from file (see page 32)

5.11.1 Load protective/warning field configuration from a file

You can load an individual protective or warning field configuration file from the
PC, e.g.  from the hard disk or from an external drive.

Requirements:
• You are logged in with the Authorized Customer (AC) authorization level.
• The changed configuration file is loaded in the software.

Select Settings > Operating mode > Protective/warning fields definition.

or

Click in the topic bar on [Protective/warning fields definition].

Select File > Load protective/warning field from a file.

or

Click on .

The file selection dialog box opens. The Examples folder is preset in the 
program directory. 

Select a file and click on [Open].

The software loads the configuration file and confirms success with a 
message.

Confirm with [OK].
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5.12 Edit protective and warning fields

You can re-define the loaded protective and warning fields, change contours and
set and reset reference contours. You always edit an individual, selected
protective or warning field.

See also:
• Select protective and warning fields (see page 33)

Define protective and warning fields (see page 35)
• Change protective and warning fields (see page 38)
• Set reference contour (see page 44)

Select protective or warning field
To be able to edit a protective or warning field, you must select a field displayed
on the work space.

Select Settings > Operating mode > Protective/warning fields definition.

or

Click in the topic bar on [Protective/warning fields definition].

Select Protective/warning fields > Protective/warning field selection.

The Protective/warning field selection dialog opens.

Select an entry in the Protective/warning fields list field and confirm with [OK].

or

Select an entry in the list field .

The software highlights the field contours of the field pair to which the selected
protective or warning field belongs: the protective field contour is red and the
warning field contour is green. Field pairs displayed but not selected in the work
area are shown in gray.
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Pic. 5.2: Protective and warning fields display

1 Not selected warning field
2 Not selected protective field
3 Selected protective field
4 Selected warning field

See also, the color legend in chapter "Work space" on page 12.

3344
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5.12.1 Define protective and warning fields

You can define a selected protective or warning field by entering absolute values
for the zone contour in a dialog. You can also adjust the graphic display of the
zone contour continuously (stepless). You can then change the zone contour.

Change numerically
Requirements:

• You are logged in with the Authorized Customer (AC) authorization level.
• The changed configuration file is loaded in the software.
• The protective or warning field is selected.

Select Settings > Operating mode > Protective/warning fields definition.

or

Click in the topic bar on [Protective/warning fields definition].

Select Protective/warning fields > Define > Numerical field entry.

or

Click on .

The Define protective/warning field dialog opens.

Enter the values for the front, left and right edge in mm and confirm with [OK].

When a message for angle resolution opens and you want to accept the 
incremental recommended values, confirm with [Yes].

The software closes the dialog and re-defines the zone contour.

Change graphically
You can define a selected protective or warning field on the work space as an
ellipse, a rectangle or a polygon. 
With the graphical definition of a definition or warning field, the cursor changes to
a hand with pointed index finger. Use the hand as a tool to define the zone limits. 
You can create a preview of the zone contour by holding the left mouse button
pressed while you move the hand tool across the work space. 



Operate

36 RS4soft Leuze electronic

If you define an ellipse or a rectangle, the cursor position corresponds with the
interface formed by the horizontal and vertical zone contour. It is immaterial here
whether the cursor is positioned left or right of the Y axis. The software mirrors the
zone contour symmetrically along the Y axis.
Requirements:

• You are logged in with the Authorized Customer (AC) authorization level.
• The changed configuration file is loaded in the software.
• The protective or warning field is selected.

Define ellipse

Select Settings > Operating mode > Protective/warning fields definition.

or

Click in the topic bar on [Protective/warning fields definition].

Select Protective/warning fields > Define > elliptical zone.

or

Click on .

The cursor changes to a hand with pointed index finger.

To mark the interface of the horizontal and vertical line for the ellipse maximum, 
position the cursor at the corresponding point on the work space. 

Left click and hold the button pressed.

The software shows a thin line as a preview of the elliptical zone, in addition to 
the existing zone.

Check the X and Y values of the cursor position in the navigation area.

Release the left mouse button when the elliptical zone has the desired shape.

The software accepts the symmetrical elliptical shape for the selected 
protective or warning field. 
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Define rectangle

Select Settings > Operating mode > Protective/warning fields definition.

or

Click in the topic bar on [Protective/warning fields definition].

Select Protective/warning fields > Define > rectangular zone.

or

Click on .

The cursor changes to a hand with pointed index finger.

To mark the interface of the horizontal and vertical contour of the rectangle, 
position the cursor at the corresponding point on the work space. 

Left click and hold the button pressed.

The software shows a thin line as a preview of the rectangular zone, in 
addition to the existing zone.

Check the X and Y values of the cursor position in the navigation area.

Release the left mouse button when the rectangular zone has the desired 
shape.

The software accepts the symmetrical rectangle shape for the protective or 
warning field. 

Define polygon
The order in which you set the corner points of the polygon depends on the
selected contour display:

• If the Safety Sensor is displayed below on the work space, set the corner 
points beside one another from left to right.

• If the Safety Sensor is displayed above on the work space, set the corner 
points beside one another from right to left.

Select Settings > Operating mode > Protective/warning fields definition.

or

Click in the topic bar on [Protective/warning fields definition].
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Select Protective/warning fields > Define > polygonal zone.

or

Click on .

The cursor changes to a hand with pointed index finger.

To define the first corner point of the polygon, position the cursor at the 
corresponding point on the work space.

Left click and hold the button pressed.

The software shows a thin line as a preview of the polygon section, in addition 
to the existing zone.

Check the X and Y values of the cursor position in the navigation area.

When the cursor is positioned at the desired point release the left mouse 
button.

Set further corner points until the polygon has the desired shape.

To correct a polygon section, click on the [Delete polygon contour course in 
steps] button.

Select [ESC] to delete all polygon sections.

When you have completed the polygon shape, the software connects the end
points and accepts the contour for the protective or warning field.

5.12.2 Change protective and warning fields

You can change a previously defined and selected protective or warning field by
changing individual segments of the zone contour, which reduce the zone limits
or blank out one or more segments.

Requirements:
• You are logged in with the Authorized Customer (AC) authorization level.
• The changed configuration file is loaded in the software.
• The protective or warning field is selected.
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Change segments
This function allows you, for example,  to enlarge an elliptical warning field by
sections.
You can change the course of an individual zone contour between a starting point
and an end point by setting two coordinate points on the selected protective or
warning field contour. The software connects the contour lying between the two
points with a straight line. The software also generates two connection lines
between old and new contour in the direction of the Safety Sensor's beam level. 

Pic. 5.3: Change segments

1 First coordinate point
2 Connection line
3 Second coordinate point
4 Beam axis

44
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Select Settings > Operating mode > Protective/warning fields definition.

or

Click in the topic bar on [Protective/warning fields definition].

Select Protective/warning fields > Change > Change segments.

or

Click on .

The cursor changes to a hand with pointed index finger.
The software displays the selected contour in bold.

To define the first point of the segment to be changed, position the cursor at 
the corresponding point on the work space.

Left click and hold the button pressed.

The software shows a thin line as a preview of the segment connection line, in 
addition to the existing zone.

Check the X and Y values of the cursor position and angle and radius in the 
navigation area.

Release the left mouse button when the cursor is positioned at the desired 
point.

The software shows a connection line from the Safety Sensor to the starting 
point of the segment to be changed.

To define the second point of the segment to be changed, position the cursor 
at the corresponding point on the work space.

Left click and hold the button pressed.

The software shows a thin line as a preview of the segment connection line, in 
addition to the existing zone.

Check the X and Y values of the cursor position and angle and radius in the 
navigation area.

When the cursor is positioned at the desired point, release the left mouse 
button or click on the work surface.

The software draws a straight connection line from the first to the second 
coordinate point.

Set as many coordinate points as needed until the segment has the desired 
shape.

The software draws a connection line from the last coordinate point to the Safety
Sensor and changes the zone contour according to the new segment line.
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Change segments with all zones
This function allows you to change sections with all protective or warning fields at
the same time. 

Select Protective/warning fields > Change > Change several segments.

or

Click on .

Change the protective or warning field contour (See chapter, "Change 
segments", page 39).

Reduce field limits
You can reduce the zone limits of a selected protective or warning field by entering
absolute values for the zone limits in a dialog.
Requirements:

• You are logged in with the Authorized Customer (AC) authorization level.
• The changed configuration file is loaded in the software.
• The protective or warning field is selected.

Select Settings > Operating mode > Protective/warning fields definition.

or

Click in the topic bar on [Protective/warning fields definition].

Select Protective/warning fields > Change > Reduce zone limits.

or

Click on .

The Change protective/warning field dialog opens.

Enter a new value for the front, left or right edge in mm and confirm with [OK].
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Blank out segments
This function allows you, for example,  to reduce a rectangular warning field in pie-
piece shapes.
You can blank out individual zone segments between a starting and an end point
by setting two coordinate points on the selected protective or warning field
contour. The software blanks out the segment lying between the points in the
direction of the Safety Sensor's beam axis. 

Pic. 5.4: Blank out segments

1 Starting point
2 Blanked out segment

1122
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Select Settings > Operating mode > Protective/warning fields definition.

or

Click in the topic bar on [Protective/warning fields definition].

Select Protective/warning fields > Change > Blank out segments.

or

Click on .

The cursor changes to a hand with pointed index finger.

To define the first point of the segment, position the cursor at the 
corresponding point on the work space.

Left click and hold the button pressed.

The software shows a thin line as a preview of the segment limit, in addition to 
the existing zone.

Check the X and Y values of the cursor position and angle and radius in the 
navigation area.

When the cursor is positioned at the desired point, release the left mouse 
button or click on the work surface.

The software shows a connection line from the Safety Sensor to the starting 
point of the segment to be blanked out.

To define the second point of the segment, position the cursor at the 
corresponding point on the work space.

Left click and hold the button pressed.

The software shows the segment area to be blanked out as a gray preview, in 
addition to the existing zone.

Check the X and Y values of the cursor position and angle and radius in the 
navigation area.

When the cursor is positioned at the desired point, release the left mouse 
button or click on the work surface.

The software draws a connection line from the Safety Sensor to the end point of
the segment to be blanked out and cuts the zone contour around the segment.
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5.12.3 Set reference contour

You can create a reference contour in a protective field by setting two coordinate
points on the selected protective field contour. The software defines the contour
line lying between the points as the reference contour and identifies the reference
contour in blue. You cannot set a reference contour in a warning field.
If the Passage control, Arm protection or Hand protection application is selected
in the configuration, the software automatically defines the entire protective field
limit as reference contour. You can reset parts of the reference contour
retroactively. 

Pic. 5.5: Set reference contour

1 Reference contour
2 Transition area between protective field contour and reference contour
3 Safety Sensor

2211 33
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Requirements:
• You are logged in with the Authorized Customer (AC) authorization level.
• The changed configuration file is loaded in the software.
• The protective or warning field is selected.
• You have defined a segment in a protective field.

Select Settings > Operating mode > Protective/warning fields definition.

or

Click in the topic bar on [Protective/warning fields definition].

Select Protective/warning fields > Reference contour > Set.

or

Click on .

The cursor changes to a hand with pointed index finger.

To define the first point of the reference contour, position the cursor at the 
corresponding point on the selected protective field contour.

Left click and hold the button pressed.

The software shows a thin line as a preview of the reference contour limit, in 
addition to the existing zone contour.

Check the X and Y values of the cursor position and angle and radius in the 
navigation area.

Release the left mouse button when the cursor is positioned at the desired 
point.

The software shows a connection line from the Safety Sensor to the starting 
point of the reference contour.

To define the second point of the reference contour, position the cursor at the 
corresponding point on the selected protective field contour.

Left click and hold the button pressed.

The software shows a blue area as a preview of the reference contour limit, in 
addition to the existing zone contour.

Check the X and Y values of the cursor position and angle and radius in the 
navigation area.

When setting the reference contour, ensure smooth transitions between
protective field segments with reference contour and protective field segments
without reference contour. The reference contour must lie on the measured
contour; the protective field limit slightly before the measured contour.
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Release the left mouse button when the cursor is positioned at the desired 
point.

The software shows a blue connection line from the starting point to the end 
point of the reference contour.

If you want to create a reference contour that consists of several sections, 
repeat the process until the contour corresponds with the desired display.

If you want to delete a reference contour, select Protective/warning fields > 
Reference contour > Reset and proceed in the reverse order.

or

Click on .

5.13 Save protective/warning field

You can save protective and warning fields as follows:

• When you save a Safety Sensor configuration, the software automatically 
also saves all loaded protective and warning fields in the configuration file 
(see chapter, "Save Safety Sensor configuration", page 28).

• You can save the selected protective or warning field individually in a 
protective/warning field configuration file (see page 46).

• You can transfer one or more of the displayed protective or warning fields 
together from the PC to the Safety Sensor and save them there (see 
page 47).

5.13.1 Save as a file

You can save the selected protective or warning field configuration on the PC,
e.g.  on the hard disk or on an external drive. 

If, for example,  a Safety Sensor is not connected with the PC, you can load the
changed protective/warning field configuration on the PC as a file, then load it
again and transfer it to the Safety Sensor.
For complicated zone contours or zones that supplement one another in
switchover mode, you can transfer a saved protective/warning field
configuration to another field pair.
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Requirements:
• You are logged in with the Authorized Customer (AC) authorization level.
• The protective or warning field is loaded in the software and selected.

Select Settings > Operating mode > Protective/warning fields definition.

or

Click in the topic bar on [Protective/warning fields definition].

Select File > Save protective/warning field as a file.

or

Click on .

The dialog box for saving opens. The Examples folder is preset in the 
program directory. 

Provide the file with a name and click on [Save].

The software saves the protective/warning field configuration file in the *.rs format.

5.13.2 Transfer from the PC to the Safety Sensor

You can transfer one or more zone configurations to the Safety Sensor so that the
changed protective or warning field configurations become effective. 

Requirements:
• The software is connected with the Safety Sensor.
• You are logged in with the Authorized Customer (AC) authorization level.
• The protective or warning fields are loaded in the software.
• The changed protective or warning fields are selected.

Select Settings > Operating mode > Protective/warning fields definition.

or

Click in the topic bar on [Protective/warning fields definition].

Select Protective/warning fields > Transfer from PC to scanner. 

The software checks the data of the connected Safety Sensor. 

The Transfer changed zones to the scanner message opens with a list of all 
changed protective and warning fields. 
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If you do not want to transfer a protective or warning field to the Safety Sensor, 
deactivate the checkbox in front of the zone name.

Confirm the message with the [Transfer] button.

The software transfers the selected protective/warning configuration file to the 
Safety Sensor. 

The Safety Sensor sends echo data to the PC.

A Scanner protective field echo data message opens for every transferred 
protective/warning field. The echo data presents the changed protective field 
graphically and numerically and shows administrative and safety-relevant 
parameters.

Check the protective field echo data of all protective fields and confirm 
accordingly with [Accept].

The software checks the configuration file and transfers it to the Safety Sensor 
again.
The Transfer protective/warning data from PC to scanner message opens.

Confirm the message with [OK].

The software has saved the changed protective and warning field files in the
Safety Sensor. 
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5.14 Document configurations

You can print the following data to document information about the configuration
of the Safety Sensor and the protective and warning fields:

• Status information (see page 49)
• Safety Sensor configuration (see page 50)
• Protective/warning field configuration (see page 51)
• Diagram (see page 51)

5.14.1 Print status information

You can print the Safety Sensor's status information or save it as a text file.
The Safety Sensor's status information includes the following information:

• Administrative parameters, e.g.  name, serial number 
• Safety-relevant parameters, e.g.  protective field additional distance values, 

startup process
• Permitted field pair switchovers
• Date a zone was last saved
• Output resolution

Requirements:
• The software is connected with the Safety Sensor.
• You have loaded the status information from the Safety Sensor.

Select the menu items Settings > Operating mode > System data.

or

Click in the topic bar on the [System data] entry.

Select System data > Load status information from scanner.

or

Click on .

The Scanner status information dialog appears.

Click on [Print] to select a printer.

Click on [Create text file] to create a text file.

If a printer is not connected you can save the information as a file in the *.txt
format.
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5.14.2 Print Safety Sensor configuration

You can print the Safety Sensor's configuration or save it as a text file.
The printout and the text file include the following information:

• Print date
• User
• Data source
• Administrative parameters
• Safety-relevant parameters
• MotionMonitoring function parameters

Name of all field pairs and date they were saved

Requirements:
• The software is connected with the Safety Sensor.
• You have loaded the status information from the Safety Sensor.

Printing

Select Settings > Operating mode > Configuration.

or

Click in the topic bar on [Configuration].

Select Configuration > Print.

or

Click on .

Create text file

Select Settings > Operating mode > Configuration.

or

Click in the topic bar on [Configuration].

Select Configuration > Change.

or

Click on .

The Configuration parameters dialog box opens.

Click on [Create text file].
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5.14.3 Print protective/warning field configuration

You can print a protective/warning field configuration
The printout and the text file include the following information:

• Name and description of the zone
• Date the zone was last saved
• Permitted field pair switchovers
• Print date
• User
• Data source
• Serial number
• Safety Sensor name
• Graphic display of the zone
• Maximum values
• Blanked out segments

Requirements:

• The software is connected with the Safety Sensor.
• A Safety Sensor configuration is loaded in the software.

Select Settings > Operating mode > Protective/warning fields definition.

or

Click in the topic bar on [Protective/warning fields definition].

Select Protective/warning fields > Print.

or

Click on .

The Print protective/warning fields dialog opens.

You can select the protective/warning field and optimize the display. 

Click on [Print].

5.14.4 Print diagram

You can save and then print diagrams shown on the work space as bitmap files in
the *.bmp format.

Requirements:
• The software is connected with the Safety Sensor.
• A Safety Sensor configuration is loaded in the software.

Select View > Save diagram as a file.
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5.15 Calibrate the front screen

If you have swapped out the Safety Sensor's front screen, e.g.  because of dirt,
you must calibrate the new front screen. The fault-free functioning of the Safety
Sensor can no longer be guaranteed if you do not.

Requirements:
• The Safety Sensor's front screen is replaced.
• The Safety Sensor is connected with the PC.
• The ambient temperature is between 20 and 25 °C.
• You are logged in with the Authorized Customer (AC) authorization level.

Select the menu items Settings > Operating mode > System data.

or

Click in the topic bar on the [System data] entry.

Select System data > Calibrate front screen.

or

Click on .

CAUTION

Faulty calibration caused by dirty or scratched front screen

Only calibrate front screens that are as good as new and clean

Clean the front screen with RS4-Clean-Set (available from accessories).
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The Calibrate the front screen dialog opens:

In the Calibration password field enter the password FS8LED and click on 
[Calibrate]. 

The software starts the comparison of the front screen calibration and shows 
the calculated values of the front screen measured distances and the 
reference distances in the dialog.

Click on [Close] to close the dialog.

You have calibrated the new front screen and can use the Safety Sensor again.
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5.16 Change password

You can change the password with which users of the Maintainer (Ma) or
Authorized Customer (AC) authorization levels log in on the Safety Sensor. 
Examples:

• With the first login on the Safety Sensor, users of the authorization levels 
Maintainer (Ma) or Authorized Customer (AC) use the Default password 
(see page 18). You must then change the Default password to a specific 
password. More information on passwords and authorization levels is 
provided in chapter "Authorization concept" on page 16.

• A user of the Maintainer (Ma) authorization level has forgotten the 
password or entered it wrong several times.

Requirements:
• You are logged in with the Authorized Customer (AC) authorization level.
• The software is connected with the Safety Sensor.

Select Security > Change password.

The Change password dialog opens.

In the Password selection list select the authorization level for which you want 
to change the default password. 

Enter the new password in the New password field, repeat the entry in the 
Repeat password field and confirm with [OK].

The software contacts the connected Safety Sensor and saves the specific
password in the Safety Sensor.

A password must be at least six and maximum eight characters long. You can
combine letters and numbers and use both lower and uppercase.
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5.17 Reset password

If a user of the Authorized Customer (AC) authorization level has forgotten their
password or entered it wrong several times,they cannot log in on the Safety
Sensor. The Change password function is therefore not available.

Instead you must reset the password. You do not require a password-protected
login to do this. The Reset password function is available for users of the
Operator (Op) authorization level. During a telephone call with the Service
department you create a one-time valid password, which the manufacturer
confirms and you subsequently change.

Requirements:
• You are logged in with the Operator (Op) authorization level.
• The software is connected with the Safety Sensor.

Get in contact

Send an e-mail to service.schuetzen@leuze.de with the following information: 

Your company address 
A telephone number where you can be reached 
Your user name
Safety Sensor serial number

or

Contact your responsible Leuze sales partner and provide them with the 
information named above.

The Service department will call you back and ask you to perform the following 
steps during the telephone call:

Create a one-time password

Select Security > Reset password.

The Set new password with one-time password dialog opens.

On the Create one-time password tab select [Create].

The software loads the one-time password from the Safety Sensor and shows 
it in red writing in the dialog, e.g.  0570DHYG.

Name the displayed one-time password for the Service department employee.

The employee then creates a new password online and names the new 
password for you.
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Set new password

Select the Set new password tab and enter the confirmed one-time password 
in the Confirmed one-time password field.

Enter the new password in the New password field, repeat the entry in the 
Repeat password field and confirm with [OK].

The software contacts the connected Safety Sensor and saves the new password
for the Authorized Customer (AC) authorization level in the Safety Sensor.
The new password is effective after a restart of the software.

5.18 Create diagnostics list and service file

5.18.1 Create diagnostics list

You can load an incident list from the Safety Sensor. With the diagnostics list you
can identify errors and define measures (see "Safe implementing" operating
instructions).
The diagnostics list contains the following information:

• Safety Sensor serial number
• Firmware version
• Date the diagnostics list was created
• List of the eight last incidents that happened with place, number, parameters

Requirement:
• The software is connected with the Safety Sensor.

Select the menu items Settings > Operating mode > System data.

or

Click in the topic bar on the [System data] entry.

Select System data > Display scanner diagnostics list.

or

Click on .

The Diagnostics list dialog box opens.

Click on [Re-load] to update the diagnostics list.

Click on [Print] to print the diagnostics list.

Click on [Save] to save the diagnostics list in the *.txt format.
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5.18.2 Create service file

You can create a service file in the *.sdc format, which contains the configuration,
diagnostics and system data of the connected Safety Sensor. 
If you mail the service file to Support, the manufacturer can diagnose possible
errors with remote diagnostics. 
Requirement:

• The software is connected with the Safety Sensor.

Select the menu items Settings > Operating mode > System data.

or

Click in the topic bar on the [System data] entry.

Select System data > Create service file.

or

Click on .

A dialog for saving the service file opens.

Provide the file with a name and click on [Save].

The software saves the service file in the *.sf format.

Send an e-mail with the service file to service.schuetzen@leuze.de with the 
following information: 

Your company address 
A telephone number where you can be reached 
Your user name
Safety Sensor serial number 
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6 Menu item reference
You will find overviews of all menu items and buttons in chapter Menu item
reference.

6.1 Menu

The Menu chapter will provide you with an overview of all menus and menu items.

6.1.1 File

Table 6.1: Menu items in the File menu

You will find further information on the interface in chapter "Screen setup" on
page 10.

Please note that the available menu items depend on both the selected
authorization level and the selected operating mode:
If, for example,  you want to configure the Safety Sensor, you must be logged in
with the Authorized Customer (AC) authorized level and be in the
Configuration operating mode.

Menu item Function

Load protective/warning field from a file Opens a single protective or warning field 
configuration file (see page 32).

Save protective/warning field as a file Saves a selected protective or warning field 
configuration as a file (see page 46).

Load configuration data from file Opens a Safety Sensor configuration file (see 
page 21).

Save configuration data as a file Saves the loaded Safety Sensor configuration 
as a file (see page 30).

Exit configuration program Exits the software.
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6.1.2 View

Table 6.2: Menu items in the View menu

6.1.3 Settings

Table 6.3: Menu items in the Settings menu

Menu item Function

Zoom Reduces the work space and the displayed 
diagram in steps.

Unzoom Enlarges the work space and the displayed 
diagram in steps.

Show all Enlarges the work space and the displayed 
diagram to full size of 70 x 70 meters.

Save diagram as a file Saves the displayed diagram as a bitmap file 
in the *.bmp format.

Menu item Submenu Function

Operating mode Measured contour display Changes to the Measured 
contour display operating 
mode.

Configuration Changes to the 
Configuration operating 
mode.

Protective/warning fields definition Changes to the Protective/
warning fields definition 
operating mode.

System data Changes to the System data 
operating mode.
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PC configuration Interface Opens a dialog box in which 
you select the serial interface 
and the transfer rate.

Languages Opens a dialog box in which 
you select the language of the 
interface texts.

Change diagram color Changes the color of the work 
space from black to white to 
optimize it for printouts.

Rotate contour display by 180° Rotates the contour display on 
the work space to adjust the 
display to the Safety Sensor's 
mounting situation.

190° protective/warning fields Extends the display of the 
protective/warning fields for 
the definition by 10°. This 
setting does not change the 
measured value recording. 

Field pair display Opens a dialog box in which 
you select displayed field pairs 
on the work space.

Activities list Opens a message that 
displays all communication 
processes performed since 
the software was last started.
With the MotionMonitoring 
function, the activities list 
shows the individual actions 
and provides the status of the 
speed monitoring.

Menu item Submenu Function
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6.1.4 Configuration

Table 6.4: Menu items in the Configuration menu

Menu item Function

Wizard Opens the configuration wizard, with which 
you change the parameters (see page 24).

Change Opens a dialog in which you change individual 
parameters (see page 25).

Set default values in the scanner Sets the Safety Sensor's configuration back to 
the delivery status (see page 8).

Printing Prints the configuration file (see page 50).

Load from file and transfer to scanner Opens an existing configuration file and 
transfers the data to the Safety Sensor (see 
page 28).

Get from scanner Loads the configuration file from the Safety 
Sensor into the software (see page 23).

Transfer from PC to scanner Transfers the configuration file to the Safety 
Sensor (see page 28).
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6.1.5 Protective/warning fields

Table 6.5: Menu items in the Protective/warning fields menu

Menu item Submenu Function

Protective/warning field selection Opens a dialog box in which you 
select the displayed protective/
warning field (see page 33).

Changed protective/warning fields Opens a dialog box in which all 
protective/warning fields that were 
changed since the last save are 
marked.

Define Numerical field entry Opens a dialog box in which you 
define the edges of a selected 
protective/warning field (see 
page 35).

Elliptical zone Enables an elliptical protective/
warning field to be defined on the 
work space (see page 35).

Rectangular zone Enables a rectangular protective/
warning field to be defined on the 
work space (see page 35).

Polygon zone Enables a polygonal protective/
warning field to be defined on the 
work space (see page 35).
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Change Change segments Enables a segment to be defined in 
the selected protective/warning 
field contour (see page 38).

Change segment several 
times

Enables a segment of all 
protective/warning field contours to 
be defined at the same time (see 
page 41).

Reduce zone limits Opens a dialog box in which you 
reduce the zone limits of the 
selected protective/warning field 
(see page 38).

Blank out segments Enables a segment to be blanked 
out in the selected protective/
warning field contour (see 
page 38). 

Reference contour Set Enables a reference contour to be 
defined in the selected protective 
field contour (see page 44).

Reset Enables a reference contour to be 
highlighted in the selected 
protective field contour (see 
page 44).

Delete Deletes the selected protective or 
warning field.

Printing Prints the graphic display and 
some parameters of the selected 
protective/warning field (see 
page 51).

Transfer from PC to 
scanner

Transfers one or more selected 
protective/warning field 
configurations to the Safety Sensor 
(see page 47).

Menu item Submenu Function
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6.1.6 System data

Table 6.6: Menu items in the System data menu

6.1.7 Safety

Table 6.7: Menu items in the Security menu

Menu item Function

Load status information from the Safety 
Sensor

Transfers the status information from the 
Safety Sensor to the software (see page 18).

Display the scanner's diagnostics list Loads an incident list from the Safety Sensor 
and opens the list in a dialog box (see 
page 56).

Create service file Opens a dialog box to save the service file in 
the *.sdc format. (see page 57).

Calibrate the front screen Opens a dialog in which you calibrate a new 
front screen (see page 52).

Reset scanner Resets the safety-related switching outputs on 
the Safety Sensor (Reset), required, for 
example,  after cleaning.

Menu item Function

Change authorization level Opens a dialog box in which you can log in 
with another authorization level (see page 18).

Change password Opens a dialog box in which you enter a new 
password for the selected authorization level 
for the login on the Safety Sensor (see 
page 54).

Reset password Opens a dialog box in which you enter a new 
password for the Authorized Customer 
(AC)authorization level for the login on the 
Safety Sensor (see page 55).
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6.1.8 Help

Table 6.8: Menu items in the Help menu

6.2 Buttons

On the topic bar you are provided the standard buttons of the toolbar as well as
some topical buttons (see chapter, "Topic bar", page 11).

6.2.1 Toolbar

You will find the toolbar on all tabs of the topic bar. The toolbar contains the
following buttons for standard functions:

Menu item Function

Implement RS4 Opens the Safety Sensor's operating 
instructions as a PDF file.

Operate RS4soft Opens the operating instructions of the 
configuration and diagnostics software as a 
PDF.

Info Opens a message with information on the 
software version

Icon Button Function

Zoom Reduces the work space and the displayed 
diagram in steps.

Unzoom Enlarges the work space and the displayed 
diagram in steps.

Show all Enlarges the work space and the displayed 
diagram to full size of 70 x 70 meters.

Change authorization level Opens the Change authorization level 
dialog box. You can log in with another 
authorization level (see chapter, "Login", 
page 18).

Exit configuration program Exits the software.
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6.2.2 Measured contour display

In addition to the toolbar, you can also use the following buttons in the Measured
contour display operating mode.

6.2.3 Configuration

In addition to the toolbar, you can also use the following buttons in the
Configuration operating mode.

Icon Button Function

Displayed field pairs selection See "Settings" on page 59.

Icon Button Function

Load configuration data from 
file

See "Load from file" on page 21.

Save configuration data as a 
file

See "Save configuration data as a file" on 
page 30.

Print configuration data See "Print Safety Sensor configuration" on 
page 50.

Load configuration data from a 
file and transfer to scanner

See "Configuration" on page 61.

Get configuration data from 
scanner

See "Get from the Safety Sensor" on page 23.

Transfer configuration data 
from PC to scanner

See "Transfer configuration data from the PC 
to the Safety Sensor" on page 28.

Change configuration data with 
the wizard

See "Change parameters with the 
configuration wizard" on page 24.

Change configuration data See "Change individual parameters" on 
page 25.

Set default configuration 
values in the scanner

See "Configuration" on page 61.
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6.2.4 Protective/warning fields definition

In addition to the toolbar, you can also use the following buttons in the Protective/
warning fields definition operating mode.

Icon Button Function

Displayed field pairs selection See "Settings" on page 59.

Load protective/warning field 
from a file

See "Load protective/warning field 
configuration from a file" on page 32.

Save protective/warning field 
as a file

See "Save as a file" on page 46.

Print protective/warning field See "Print protective/warning field 
configuration" on page 51.

See "Select protective or warning field" on 
page 33.

Select protective/warning field 

Enter protective/warning field 
numerically

See "Change numerically" on page 35.

Define elliptical protective/
warning field

See "Change graphically" on page 35.

Define rectangular protective/
warning field

See "Change graphically" on page 35.

Define polygonal protective/
warning field

See "Change graphically" on page 35.

Change protective/warning 
segment

See "Change segments" on page 39.

Change protective/warning 
segment with all fieldf

See "Change segments with all zones" on 
page 41.

Reduce protective/warning 
field limits

See "Reduce field limits" on page 41.

Blank out protective/warning 
field segment

See "Blank out segments" on page 42.

Define protective field segment 
as reference contour

See "Set reference contour" on page 44.
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6.2.5 System data

In addition to the toolbar, you can also use the following buttons in the Protective/
warning fields definition operating mode.

Reset reference contour 
definition for protective field 
segment

See "Set reference contour" on page 44.

Delete protective/warning field See "Protective/warning fields" on page 62.

Transfer changed protective/
warning fields from PC to 
scanner

See "Transfer from the PC to the Safety 
Sensor" on page 47.

Icon Button Function

Icon Button Function

Transfer status information 
from scanner to PC

See "Print status information" on page 49.

Display the scanner's 
diagnostics list

See "Create diagnostics list" on page 56.

Create service file See "Create service file" on page 57.

Calibrate the front screen See "Calibrate the front screen" on page 52.

Reset scanner See "System data" on page 64.
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